Upgrade FC4 to FC5 with yum

I recently upgraded a bunch of FC4 (a few FC3) installs to FC5 using yum. It has been a long time since I've tried doing an OS upgrade like this because it used to be pretty painful. I was surprised at how easy it is to do now. There are a few issues to get past but for the most part for fedora core 4 to fedora core 5 you just have to follow a few simple steps:

  1. Remove any kernels before 2.6.14. There are packages that will not allow you to upgrade unless you do this step. Use the yum command: yum remove kernel-2.6.14* or the rpm command rpm -e kernel-2.6.14*
  2. Even though it isn't in the documentation I have had trouble in the past with some dependancies not working out correctly so I like to run "yum clean all" before starting the true upgrade.
  3. Install the fedora-release for Fedora Core 5. Use the rpm command: rpm -Uhv http://download.fedora.redhat.com/pub/fedora/linux/core/5/i386/os/Fedora/RPMS/fedora-release-5-5.noarch.rpm
  4. Run the yum update: yum -y update

That is all there is to it.

For more details see the following links:

YumUpgradeFaq and a good post on doing a FC4 to FC5 upgade.

Tags: , ,

12 thoughts on “Upgrade FC4 to FC5 with yum

  1. Pingback: Upgrade FC5 to FC6 with yum @ IONCANNON

  2. Alexey

    i have trouble with update FC4 to FC5

    –> Processing Dependency: libcrypto.so.5 for package: qmail-toaster
    –> Processing Dependency: libssl.so.5 for package: spamassassin-toaster
    –> Processing Conflict: djbdns conflicts bind
    –> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14) for package: qmail-toaster
    –> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14) for package: courier-authlib-toaster
    –> Processing Dependency: libcrypto.so.5 for package: spamassassin-toaster
    –> Processing Dependency: libssl.so.5 for package: qmail-toaster
    –> Processing Dependency: libcrypto.so.5 for package: libdomainkeys-toaster
    –> Processing Conflict: djbdns conflicts caching-nameserver
    –> Finished Dependency Resolution
    Error: Missing Dependency: libcrypto.so.5 is needed by package spamassassin-toaster
    Error: Missing Dependency: libssl.so.5 is needed by package spamassassin-toaster
    Error: Missing Dependency: libcrypto.so.5 is needed by package libdomainkeys-toaster
    Error: Missing Dependency: libssl.so.5 is needed by package qmail-toaster
    Error: Missing Dependency: libmysqlclient.so.14(libmysqlclient_14) is needed by package courier-authlib-toaster
    Error: Missing Dependency: libcrypto.so.5 is needed by package qmail-toaster
    Error: Missing Dependency: libmysqlclient.so.14(libmysqlclient_14) is needed by package qmail-toaster
    Error: djbdns conflicts with bind
    Error: djbdns conflicts with caching-nameserver

  3. Leon

    Hello, all and Alexey especially!

    i have the same problem with libssl.so.5 and libcrypto.so.5, just with the clamav package.

    How one can overcome this problem? Alexey, have you succeeded?

  4. Prakash

    I upgrade from FC4 to FC6 directly online & have not any problems. I did it on my laptop & trying the on my desktop.

  5. Prakash

    Hello,
    I have following erroe while FC4 to FC6 upgrade of my Desktop AMD 2400+ VIA chipset KT4V 6712 MSI Main Board with kingston 512 MB RAM.
    Please any body have solution. Please replay to me.

    –> Running transaction check
    Error: Missing Dependency: mozilla = 37:1.7.8-2 is needed by package mozilla-mail
    Error: Missing Dependency: libgnomecanvaspixbuf.so.1 is needed by package gtkhtml
    Error: Missing Dependency: mozilla = 37:1.7.8-2 is needed by package mozilla-chat
    Error: Missing Dependency: libgcj.so.6 is needed by package eclipse-pydev
    Error: Missing Dependency: libgcj.so.6 is needed by package struts11
    Error: Missing Dependency: hpoj = 0.91-13 is needed by package hpoj-devel
    Error: Missing Dependency: libcrypto.so.5 is needed by package ckermit
    Error: Missing Dependency: mozilla = 37:1.7.8-2 is needed by package mozilla-dom-inspector
    Error: Missing Dependency: libcrypto.so.5 is needed by package perl-RPM2
    Error: Missing Dependency: /usr/X11R6/lib/X11/XKeysymDB is needed by package openmotif
    Error: Missing Dependency: mozilla = 37:1.7.8-2 is needed by package mozilla-js-debugger
    Error: Missing Dependency: libssl.so.5 is needed by package ckermit
    Error: Missing Dependency: libssl.so.5 is needed by package perl-RPM2
    Error: Unable to satisfy dependencies
    Error: Package hpoj-devel needs hpoj = 0.91-13, this is not available.
    Error: Package openmotif needs /usr/X11R6/lib/X11/XKeysymDB, this is not available.
    Error: Package ckermit needs libcrypto.so.5, this is not available.
    Error: Package mozilla-js-debugger needs mozilla = 37:1.7.8-2, this is not available.
    Error: Package perl-RPM2 needs libcrypto.so.5, this is not available.
    Error: Package mozilla-dom-inspector needs mozilla = 37:1.7.8-2, this is not available.
    Error: Package kudzu needs kernel

  6. eugene

    Please try to read
    http://www.brandonhutchinson.com/Upgrading_Red_Hat_Linux_with_yum.html

    If this step fails, I recommend running the following command to capture all screen output to /tmp/yum_upgrade.

    # yum upgrade 2>&1 | tee /tmp/yum_upgrade

    Failures generally indicate that a currently-installed RPM has a dependency that cannot be satisfied with packages from the new Fedora Core release. Deprecated packages and packages from third party repositories may cause this problem.

    The following generates a list of packages that may need to be removed prior to a successful yum upgrade.
    $ perl -ne 'print "$1\n" if ((/Error: Missing Dependency:.*is needed by package (.*)$/) || (/Error: Package (.*?) needs.*, this is not available./))' /tmp/yum_upgrade | sort | uniq

  7. Andy

    Has anyone tried this remotely on a server? When the update is performed is there any local user intervention that is required?

    Thanks,

    Andy

  8. Jon

    I did an FC4->FC5 update on a box at the house, no problems (just had to re-configure my apache, it moved the old httpd.conf file to httpd.conf.rpmsave and replaced it with a new one, the old one had some problem that were resolved by doing an ediff to merge them together… but I digress…) Now confident, I did it on my remote server. On reboot, the machine stayed up for about 30 seconds and then locked up. The techs at the datacenter ended up having to change the kernel it booted into to the old FC4 kernel.

    I'm not sure what is causing this, just now I did "rpm -qa –last > /tmp/RPMS_by_Install_Time.txt" and removed most of the packages that had an install date previous to the FC5 install. There were a couple of packages like splunk (which I never use), httpd-debug (not sure if this might be conflicting with the new apache), and mysql-debug (again, not sure if it was conflicting with the new mysql) – I'm crossing my fingers and hoping that I'll be able to do a successful reboot this weekend. Then it's off to updating to FC6 … and then 7 …

  9. Jon

    Yesterday I posted about my remote machine hanging after going from FC4->FC5, and that it was currently running in the old FC4 kernel. Tech support at the datacenter just gave me this little gem:

    "kernel-2.6.20 is known to be unstable woth fedora core 5 . we recommend you use kernel-2.6.19 kernel-2.6.18 for fedora core 5."

    Anyone else able to confirm this and recommend the best way to resolve it?

Leave a Reply

Your email address will not be published. Required fields are marked *